Информатика, вопрос задал OhmyyGod , 9 лет назад

C++Напишите программу, которая заполняет массив из N элементов случайными целыми числами в диапазоне [ A , B ] и определяет количество трёхзначных чисел в этом массиве, которые не делятся на 5.
Входная строка содержит три числа: границы диапазона случайных чисел A и B , а также размер массива N . Все числа разделены пробелами. Гарантируется, что 0 < N ≤ 10000 .
В первой строке программа должна вывести N элементов построенного массива, разделив их пробелами, а во второй строке – количество трёхзначных чисел в массиве, которые не делятся на 5.

Ответы на вопрос

Ответил averutin
0
GNU GCC.

#include <iostream>
#include <vector>
#include <cstdlib>
using namespace std;

int main()
{
int a, b, n;
cout <<"Введите границы диапазона и размер массива:" <<endl;
cin >>a >>b >>n;
if(n>10000) n=10000;
vector<int> v(n);
srand(time(0));
cout <<"Исходный массив:" <<endl;
for(int i=0; i<v.size(); ++i)
{
v[i] = rand()%(b-a+1) + a;
cout <<v[i] <<" ";
}
cout <<"n3х-значные элементы, не кратные 5:" <<endl;

for (int i=0; i<v.size(); ++i)
if ((v[i]>99) && (v[i]<1000) && (v[i]%5!=0))
cout <<v[i] <<" ";
cout <<endl;

return 0;
}
Новые вопросы