Информатика, вопрос задал Аноним , 2 года назад

C# Напишите программу, которая будет запрашивать у пользователя:

Имя

Фамилию

Год рождения

Место проживания

Затем она выведет на экран строку, которая будет содержать все введенные данные. Вместо года рождения нужно вывести, сколько лет человеку. Предполагать, что сейчас 2022 год. Предполагать, что пользователь не будет вводить неверный год рождения.

Пример вывода на экран:

Enter your name:

James

Enter your last name:

Bond

When were you born?

1980

Where are you from?

Great Britain

Hello, JAMES BOND. You are 42 years old. You are living in Great Britain.

Что должно присутствовать в коде программы:

Все переменные типа string не должны содержать лишних пробелов в начале и в конце

Имя и фамилия должны выводиться в верхнем регистре

Вывод на экран должен использовать форматирование строки

Ответы на вопрос

Ответил wherethefux
0

           Console.WriteLine("Enter your name:");

           string name = Console.ReadLine();

           Console.WriteLine("Enter your last name:");

           string lastName = Console.ReadLine();

           Console.WriteLine("When were you born?");

           string year = Console.ReadLine();

           Console.WriteLine("Where are you from?");

           string country = Console.ReadLine();

           Console.WriteLine($"Hello, {name.ToUpper()} {lastName.ToUpper()}. You are {2022 - int.Parse(year)} years old. You are living in {country}.");

Приложения:

Аноним: там еще нужно чтоб пробелов не было в string
wherethefux: "Все переменные типа string не должны содержать ЛИШНИХ пробелов в начале и в конце"
Новые вопросы