C# Написать программу, содержащую класс Студент со следующими полями: Фамилия, Имя, Возраст, Группа, Отметки (использовать целочисленный массив) и методами: вывода информации о студенте и расчет среднего значения Успеваемости
Ответы на вопрос
Ответ:
using System;
using System.Collections;
using System.Collections.Generic;
using System.Linq;
namespace CSLear
{
partial class Program
{
static void Main(string[] args)
{
Student Лёха = new Student("Свотин", "Алексей", 21, "ПИ 2-3", new int[5] { 4, 5, 3, 5, 3, });
Лёха.GetInfo();
Console.WriteLine($"Отдельно выведенные оценки Лёхи: {Лёха.AverageMark}");
Console.ReadKey();
}
}
class Student
{
public string Surname { get; set; }
public string Name { get; set; }
public int Age { get; set; }
public string Group { get; set; }
public int[] Marks { get; set; }
public double AverageMark => Marks.Average();
public Student(string Surname, string Name, int Age, string Group, int[] MarkList)
{
this.Surname = Surname;
this.Name = Name;
this.Age = Age;
this.Group = Group;
Marks = MarkList;
}
public void GetInfo()
{
Console.WriteLine($"Студент: {Surname} {Name}\nГруппа: {Group}\nСредний балл: {AverageMark}");
}
}
}
Объяснение:
Да, в VS 2019 можно использовать кириллицу для наименования переменных.