Информатика, вопрос задал 1223445565 , 2 года назад

C++
Написать программу
С клавиатуры вводятся n чисел. Составьте программу, которая определяет количество отрицательных, количество положительных и количество нулей среди введенных чисел. Значение n вводится с клавиатуры.

Ответы на вопрос

Ответил Koljisto
4

#include <iostream>

using namespace std;

int main()

{

setlocale(LC_ALL, "Russian");

int n;

int num = 0;

int i = 0;

int counter_negative = 0, counter_positive = 0, counter_zero = 0;

cout << "Введите n: ";

cin >> n;

while (i < n) {

 cout << "Введите число: ";

 cin >> num ;

 if (num > 0) counter_positive++;

 if (num < 0) counter_negative++;

 if (num == 0) counter_zero++;

 i++;

}

cout << "Положительных: " << counter_positive << endl;

cout << "Отрицательных: " << counter_negative << endl;

cout << "Нулевых: " << counter_zero << endl;

}

Новые вопросы