Информатика, вопрос задал Аноним , 2 года назад

C# Написать программу которая предложит ввести последовательно три числовых значения элементов массива. Затем предложит ввести индекс элемента массива от 0 до 2. Результатом выполнения программы должен быть вывод результатов сравнения значения элемента массива с введенным индексом со всеми другими элементами массива, включая сравнение с самими собой.
Пример вывода на экран:
Enter numeric value for first element:
14
Enter numeric value for second element:
3
Enter numeric value for third element:
115
Enter key of element for comparison:
0
Result:
1) 14 > 14 = false
2) 14 > 3 = true
3) 14 > 115 = false
Предполагается что:
Пользователь программы введет целочисленные значения элементов массива
Пользователь укажет ключ элемента массива для сравнения в диапазоне от 0 до 2
Что должно присутствовать в коде программы:
Вывести значения элементов массива с помощью конкатенации
Подсчет результатов сравнения и вывод результата на экран с помощью цикла foreach
Дополнительно можно сделать:
Вывести элементы с помощью форматирования строки
Добавить проверку то, что пользователь ввел индекс несуществующего элемента массива
Задание 2
Дан массив:
String[] message = {"on C#", "programming ", "I like "};
Необходимо вывести на экран строку "I like programming on C#". Результирующую строку нужно получить путем конкатенации в подобранных правильном порядке элементов массива message.
Что должно присутствовать в коде программы:
Вывести строку на экран с помощью конкатенации
Обращение к элементам массива по индексу


thisisandrew0110: Проверки входных данных нужно делать ?

Ответы на вопрос

Ответил thisisandrew0110
3

Ответ: смотри на фото.

Приложения:

ggwpaaa152: проект валиться
ggwpaaa152: на 1 задании
thisisandrew0110: Какие логи пишет ?
pain9024: (2,70): error CS0103: The name `elements' does not exist in the current context
pain9024: string[] elements = { "one", "two", "Three" };
var values = new int[3];

for (int i = 0; i < 3; i++)
[
Console.WriteLine($"Enter numeric value for {elements[i]}");
var input = Convert.ToInt32(Console.ReadLine());
values[i] = input;
]
Console.WriteLine("Enter key of element for comparison");
var key = CheckIndex();
var selectValue = values[key];
foreach(var value in values)
{
var result = selectValue > value;
Console.WriteLine($"{SelectValue} > {value} = {result}");
}
Новые вопросы