C++
Написать программу, используя два раза while, которая выдает следующее:
*
**
***
****
*****
******
*******
********
Я написал, но не работает. Может найдете ошибку в моей? (ошибка не в синтаксисе, а в выдаче результата)
#include
int main()
{
int verticalDown=0;
int horizontalRight=0;
int countColumns=1;
while(verticalDown<8)
{
while(horizontalRight
{
std::cout << "*";
horizontalRight++;
}
countColumns++;
verticalDown++;
std::cout << "n";
}
return 0;
}
Ответы на вопрос
Ответил clinteastwood2
0
лучше делать через for
#include <iostream>using namespace std;
int main()
{
const int N = 8;
char matrix[N][N];
for (int i = 0; i < N; i++) {
for (int j = 0; j < N; j++) {
matrix[i][j] = 0;
if (i > j) {
matrix[i][j] = '*';
}
cout << matrix[i][j] << " ";
}
cout << endl;
}
return 0;
}
#include <iostream>using namespace std;
int main()
{
const int N = 8;
char matrix[N][N];
for (int i = 0; i < N; i++) {
for (int j = 0; j < N; j++) {
matrix[i][j] = 0;
if (i > j) {
matrix[i][j] = '*';
}
cout << matrix[i][j] << " ";
}
cout << endl;
}
return 0;
}
Новые вопросы
Українська література,
2 года назад
Биология,
2 года назад
Биология,
8 лет назад
Химия,
8 лет назад
Математика,
9 лет назад