Информатика, вопрос задал jejdh666 , 7 лет назад

C++
Дан массив, состоящий из целых чисел. Напишите программу, которая подсчитает
количество элементов массива, больших предыдущего (элемента с предыдущим
номером).
Входные данные
Сначала задано число N — количество элементов в массиве (1N10000). Далее через
пробел записаны N чисел — элементы массива. Массив состоит из целых чисел.
Выходные данные
Необходимо вывести единственное число - количество элементов массива, больших
предыдущего.
Примеры
входные данные
5
1 2 3 4 5
выходные данные
4

Ответы на вопрос

Ответил Helper211
0

Ответ:

#include <iostream>

int main()

{

int N, i, k = 0;

int A[10000];

std::cin >> N;

std::cin >> A[0];

for (i = 1; i < N; i++)

{

 std::cin >> A[i];

 if (A[i] > A[i - 1]) k++;

}

std::cout << k;

return 0;

}

Новые вопросы