C++
1. Написать программу, которая выводит одномерный массив в обратном порядке.
2. Пользователь вводит длину сторон пятиугольника, каждая сторона заноситься в массив, необходимо вычислить периметр пятиугольника (периметр — сумма всех сторон).
Ответы на вопрос
Программа, выводящая одномерный массив в обратном порядке:
int main() {
const int ARRAY_SIZE = 5;
int arr[ARRAY_SIZE] = {1, 2, 3, 4, 5};
std::cout << "Original array: ";
for (int i = 0; i < ARRAY_SIZE; i++) {
std::cout << arr[i] << " ";
}
std::cout << "\nReversed array: ";
for (int i = ARRAY_SIZE - 1; i >= 0; i--) {
std::cout << arr[i] << " ";
}
return 0;
}
Программа, вычисляющая периметр пятиугольника:
int main() {
const int NUM_SIDES = 5;
double sides[NUM_SIDES];
double perimeter = 0;
std::cout << "Enter the lengths of the 5 sides of the pentagon:\n";
for (int i = 0; i < NUM_SIDES; i++) {
std::cout << "Side " << i + 1 << ": ";
std::cin >> sides[i];
perimeter += sides[i];
}
std::cout << "The perimeter of the pentagon is " << perimeter << std::endl;
return 0;
}