Информатика, вопрос задал chora , 10 лет назад

ABCpaskal:С клавиатуры вводится строка, состоящая из букв и цифр. Написать программу , определяющую количество четных цифр в строке.ПОМОГИТЕ!!!СРОЧНО!!!

Ответы на вопрос

Ответил Sky09
0
uses crt;
var s1:string;
    s2:char;
    k,y,x:integer;
begin
     readln(s1);
     k:=0;
     for x:=1 to length(s1) do
         begin
              s2:=s1[x];
              if (ord(s2)<=57) and (ord(s2)>=48) then
                 if ord(s2) mod 2=0 then inc(y);
         end;
     writeln(y);
end.
Ответил Seantrex
0
var
s1,s2:string;
i,j,k,m:longint;
begin
readln(s1);
k:=length(s1);
s2:='24680';
for i:=1 to k do
  for j:=1 to 5 do
    if s1[i]=s2[j] then inc(m);
writeln(m);
end.
ну вроде так, скомпилируй только перед отправкой или сдачей
Новые вопросы