Информатика, вопрос задал danielchemica99 , 1 год назад

ABCPascal
Составить программу, которая каждую встреченную в заданном предложении букву «р» заменяла бы сочетанием букв «ля».

Ответы на вопрос

Ответил klazik4562185
0

Відповідь:

program ReplaceRWithLya;

var

 inputString: string;

 outputString: string;

 i: integer;

begin

 inputString := 'Это предложение содержит несколько букв р.';

 outputString := '';

 for i := 1 to length(inputString) do

 begin

   if inputString[i] = 'р' then

     outputString := outputString + 'ля'

   else

     outputString := outputString + inputString[i];

 end;

 writeln(outputString);

end.

Пояснення:

Новые вопросы