Информатика, вопрос задал anzhelika06 , 8 лет назад

а)Составить программу, которая увеличивает в 10 раз все элементы массива. б) заменяет все отрицательные
элементы их индексами.
Сделать нужно и а и б.
Через паскаль.
Очень прошу, помогите пожалуйста.
Прошу, пожалуйста помогите, срочно, очень надо.

Ответы на вопрос

Ответил Gleb1Kosyrev
0
//PascalABC.NET 3.2 сборка 1318

//а

begin
  writeln('Введите размерность:');
  var n:=ReadInteger();
  writeln('Введите массив:');
  var ar:=ReadArrInteger(n);
  ar.Transform(x -> x*10);
  ar.Print;
end.

//б

begin
  writeln('Введите размерность');
  var n:=ReadInteger();
  writeln('Введите массив:');
  var ar:=ReadArrInteger(n);
  for var i:=0 to n-1 do            //индексация с 0
    if ar[i]<0 then ar[i]:=i;
  ar.Print;
end.
Новые вопросы