Информатика, вопрос задал Аноним , 7 лет назад

«A»: Напишите программу, которая находит количество четырёхзначных чисел, которые делятся на 7.
«B»: Ипполит задумал трёхзначное число, которое при делении на 15 даёт в остатке 11, а при делении на 11 даёт в остатке 9. Напишите программу, которая находит все такие числа.
«C»: С клавиатуры вводится натуральное число N. Программа должна найти факториал этого числа (обозначается как N!) – произведение всех натуральных чисел от 1 до N. Например,
5! = 1 • 2 • 3 • 4 • 5 = 120.
«D»: Натуральное число называется числом Армстронга, если сумма цифр числа, возведенных в N-ную степень (где N – количество цифр в числе) равна самому числу. Например, 153 = 13 + 53 + 33. Найдите все трёхзначные Армстронга.


Аноним: на питон

Ответы на вопрос

Ответил Fedy16
10

Python:

# A

print(len([i for i in range(1000, 10000) if i % 7 == 0]))

# B

for i in range(100, 1000):

   if all([i % 15 == 11, i % 11 == 9]):

       print(i)

# C(1)

N = int(input())

numbers = [i for i in range(1, N+1)]

result = numbers[0]

for i in numbers[1:]:

   result *= i

print(result)

# C(2)

import math

print(math.factorial(int(input())))

# D

for i in range(100, 1000):

   digits = [int(n) for n in str(i)]

   with_a_degree = [n ** len(str(i)) for n in digits]

   if sum(with_a_degree) == i:

       print(i)

Новые вопросы