Информатика, вопрос задал dragonagekeep , 8 лет назад

(99 баллов!)
Python
Напишите программу, которая находит в массиве минимальный и максимальный из чётных положительных элементов.Если в массиве нет элементов с чётными положительными значениями,нужно вывести сообщение об этом.

Ответы на вопрос

Ответил dar290199
0
mas = [int(i) for i in input('Введите массив : ').split()]
flag = 0
for i in mas:
    if i%2 == 0:
        max = min = i
        flag = 1
        break
if flag == 0:
    print('Четных нет!')
    exit()
for i in mas:
    if i%2 == 0 and i > max:
        max = i
    if i%2 == 0 and i < min:
        min = i
print(max,min) 
Ответил dar290199
0
чекай
Ответил dragonagekeep
0
Я ввожу тот же самый массив,потом он хочет что бы я ввела что-то ещё
Ответил dar290199
0
как ты вводишь?
Ответил dar290199
0
просто введи строку через пробел
Ответил dar290199
0
и нажми enter
Новые вопросы