9 класс фастом
Написать программу, заполняющую массив 30 случайными числами [-10..80].
Вывести массив.
Определить в этом массиве сумму чисел, кратных 3
Определить количество отрицательных чисел.
Определить в этом массиве номер элемента, равного 0
Ответы на вопрос
Ответил Puz1koO
1
Var a: array [1..30] of integer;
sum3,otr,i,j:integer;
begin
randomize;
sum3:=0;
otr:=0;
for i:=1 to 30 do
begin
a[i]:=random(91)-10;
write(a[i]:4);
if a[i] mod 3 = 0 then sum3:=sum3+a[i];
if a[i]<0 then inc(otr);
end;
writeln;
writeln('Sum: ',sum3,' <0:',otr);
for i:=1 to 30 do
if a[i]=0 then
begin
writeln('№',i,'=0');
end;
end.
Новые вопросы
Математика,
7 лет назад
Английский язык,
7 лет назад