80 БАЛЛОВ!!!Помогите Паскаль!!!Нужно составить программу которая проверяла является ли простым числом,введенное с клавиатуры числом
Ответы на вопрос
Ответил alexfedor932
0
program zhn;
var
n,i,sum:integer;
begin
write('Введите значение: ');
readln(n);
for i:=1 to n do begin
if n mod i = 0 then sum:=sum+1;
end;
if sum = 2 then writeln('Число ',n,' является простым.')
else writeln('Число ',n,' НЕ является простым.');
end.
var
n,i,sum:integer;
begin
write('Введите значение: ');
readln(n);
for i:=1 to n do begin
if n mod i = 0 then sum:=sum+1;
end;
if sum = 2 then writeln('Число ',n,' является простым.')
else writeln('Число ',n,' НЕ является простым.');
end.
Ответил alexfedor932
0
без разницы
Ответил Иришми
0
f cgfcb,j
Ответил alexfedor932
0
главное что бы везде было x
Ответил Иришми
0
спасибо
Ответил alexfedor932
0
вместо sum
Новые вопросы
Русский язык,
2 года назад
Математика,
2 года назад
Математика,
9 лет назад
История,
9 лет назад
Математика,
10 лет назад