Информатика, вопрос задал mspolaakerupa , 2 года назад

8. Составить программу определения вида треугольника: равносторонний, равнобедренный, разносторонний.

9. Написать программу, вычисляющую принадлежит ли точка X отрезку [а, b], используя составные условия. Если да, то выдать на экран «принадлежит» и удвоить значение X. Если нет, то выдать на экран "не принадлежит" и утроить значение X​
компилятор (С++)

Ответы на вопрос

Ответил orakul96
0

#include <iostream>

#include <iomanip>

using namespace std;

int main()

{

setlocale(LC_ALL,"rus");

cout<<"1:"<<endl;

double a,b,c;

cin>>a>>b>>c;

if(a==b && a==c && b==c)

{

 cout<<"Равносторонний"<<endl;

}

else

{

 if(a==b || a==c || b==c) cout<<"Равнобедренный"<<endl;

 else cout<<"Разносторонний"<<endl;

}

cout<<"2:"<<endl;

double i,j,x;

cin>>i>>j>>x;

if(x>=i && x<=j) cout<<"Принадлежит."<<x*2<<endl;

else cout<<"Не принадлежит."<<x*3<<endl;

system("pause");

return 0;

}

Был рад помочь!!!!!!

Новые вопросы