8. Написать программу, которая по выбору пользователя меняет цвет консольного приложения. Пользователь может выбрать цвет шрифта и цвет фона.C++ if else
Ответы на вопрос
#include <iostream>
using namespace std;
void main() {
setlocale(LC_ALL, "RUSSIAN");
char text, fon;
cout << "0 = Черныйt8 = Серыйn";
cout << "1 = Синийt9 = Светло - синийn";
cout << "2 = ЗеленыйtA = Светло - зеленыйn";
cout << "3 = ГолубойtB = Светло - голубойn";
cout << "4 = КрасныйtC = Светло - красныйn";
cout << "5 = ЛиловыйtD = Светло - лиловыйn";
cout << "6 = ЖелтыйtE = Светло - желтыйn";
cout << "7 = БелыйtF = Ярко - белыйnn";
cout << "Введите цвет фона: ";
cin >> fon;
cout << "Введите цвет текста: ";
cin >> text;
switch (fon == text){
case true:{cout << "Невозможно поменять цвета."; }
case false:{
switch (fon){
case '0':{
switch (text){
case '1':{system("color 01"); break; }
case '2':{system("color 02"); break; }
case '3':{system("color 03"); break; }
case '4':{system("color 04"); break; }
case '5':{system("color 05"); break; }
case '6':{system("color 06"); break; }
case '7':{system("color 07"); break; }
case '8':{system("color 08"); break; }
case '9':{system("color 09"); break; }
case 'a':{}
case 'A':{system("color 0A"); break; }
case 'b':{}
case 'B':{system("color 0B"); break; }
case 'c':{}
case 'C':{system("color 0C"); break; }
case 'd':{}
case 'D':{system("color 0D"); break; }
case 'e':{}
case 'E':{system("color 0E"); break; }
case 'f':{}
case 'F':{system("color 0F"); break; }
}break;
switch (fon == text){
case true:{cout << "Невозможно поменять цвета."; }
case false:{
switch (fon){
case '1':{
switch (text){
case '1':{system("color 12"); break; }
}break;
}
}break;
}
}break;
}
}
cin.get(); cin.get();
}
}
}