70 балов. Напишите программу на С++ которая решает даную задачу:
Пользователь вводит два числа.
Определить, делится ли первое число на второе без остатка. Если нет вівести ближайшее целое число,
удовлетворяющее условие
Ответы на вопрос
Ответил DigitalAnnihilator
0
Файл с исходным кодом прикреплен в описании, код продублирован в коментариях к ответу. Если есть вопросы - пиши в коменты.
Код полностью прокоментирован, надеюсь будет понятно.
Код полностью прокоментирован, надеюсь будет понятно.
Приложения:
Ответил DigitalAnnihilator
0
//основная функция программы
//-----------------------------------------------------------------------------
int main()
//-----------------------------------------------------------------------------
{
int firstNumber; //делимое
int secondNumber; //делитель
cout << "Enter number: ";
cin >> firstNumber; //вводим делимое
cout << "Enter divider: ";
cin >> secondNumber; //вводим делитель
//-----------------------------------------------------------------------------
int main()
//-----------------------------------------------------------------------------
{
int firstNumber; //делимое
int secondNumber; //делитель
cout << "Enter number: ";
cin >> firstNumber; //вводим делимое
cout << "Enter divider: ";
cin >> secondNumber; //вводим делитель
Ответил DigitalAnnihilator
0
if (isNumberDividedWhole(firstNumber, secondNumber))
{
cout << "Numbers divide whole." << endl; //если числа деляться нацело
}
else
{ //если же нет
cout << "Numbers not divide whole." << endl;
cout << "Near integer divider is: ";
//отискать ближайший делитель и вывести его
cout << getNearIntegerDivider(firstNumber, secondNumber);
cout << endl;
}
//ждать нажатия любой клавиши
system("pause");
//вернуть системе значение 0 - значит программа завершила работу корректно
return 0;
}
{
cout << "Numbers divide whole." << endl; //если числа деляться нацело
}
else
{ //если же нет
cout << "Numbers not divide whole." << endl;
cout << "Near integer divider is: ";
//отискать ближайший делитель и вывести его
cout << getNearIntegerDivider(firstNumber, secondNumber);
cout << endl;
}
//ждать нажатия любой клавиши
system("pause");
//вернуть системе значение 0 - значит программа завершила работу корректно
return 0;
}
Ответил DigitalAnnihilator
0
Спасибо за пометку лучший ответ и "спасибо")
Ответил meliorest
0
извините что так долго)
Ответил DigitalAnnihilator
0
ничего (:
Новые вопросы