Информатика, вопрос задал aprived , 7 лет назад

7. На вход программе подается натуральное число. Каких цифр в числе больше четных или нечетных. В ответ выведите 1, если больше нечетных и 0, если четных и 2, если их количество одинаково.Питон помогите плиз​

Ответы на вопрос

Ответил swaca7
0

num = input()

n = len(num)

odd = 0

noodd = 0

while i < len(num):

   if(int(num[i]) % 2 == 0):

       odd = odd + 1

   else :

       noodd = noodd + 1

if(odd == noodd):

   print(2)

elif(odd > noodd):

   print(0)

else :

   print(1)

Новые вопросы