65 БАЛЛОВ!!! СРОЧНО!!! Написать программу паскаль.
Дано n натуральных чисел, которые вводятся по одному. Найти: количество двузначных чисел, цифра десятков которых чётная, а цифра единиц - нечётная, или вывести сообщение, что таких чисел нет.
Ответы на вопрос
Ответил wensent
1
Ответ:
Program p1;
Var a, i, n, k,x,z: integer;
Begin
Write('Введите количество чисел последовательности: ');
readln(n);
k:=0;
For i:=1 to n do begin
readln (a);
x := a mod 10;
z:= (a div 10) mod 10;
if (z mod 2 = 0) and (x mod 2 = 1) then k:=k+1
end;
if k > 0 then
Writeln('Количество чисел у которых цифра десятков которых чётная, а цифра единиц - нечётная - ',k)
else
writeln('Таких чисел нет')
End.
malininmaksim6:
Спасибо !
Дано n натуральных чисел, которые вводятся по одному. Найти: произведение чисел. у меня в профиле есть
Новые вопросы
Английский язык,
2 года назад
Математика,
2 года назад
Математика,
2 года назад
Геометрия,
8 лет назад