Информатика, вопрос задал Нэсти1 , 10 лет назад

6. Точка А задана координатами X,Y. Написать программу, которая выводит слово«Принадлежит», если точка принадлежит заштрихованной области (см. рисунок 6) и «Не принадлежит» в противном случае. Программа должна иметь дружественный интерфейс. Протестировать программу для точек (0,0), (2,2), (0.5,0.5), (0.5,-1.5), 
(-0.5,0.5), (-2,-1), (-1,-2), (-1,1), (2, 0).

Приложения:

Ответы на вопрос

Ответил kage1998
0
program chik;
var x,y:real;
begin
readln(x,y);
if  ( (y<=0) and (x>=-1) and (x<=1) and (y>=-2) ) or
( (y>=0) and (x>=-1) and (x<=1) and (y<=1) and (x*x+y*y<=1))then 
writeln('ПРИНАДЛЕЖИТ') else writeln('Не принадлежит');
end.
Новые вопросы