Информатика, вопрос задал daanakerimbekova , 1 год назад

№6 Написать программу которая выдает цвета радуги. (Использовать 2 способа для получение результата)
№7 Написать программу для сравнение двух чисел.
№ 8 Создать список своих любимых блюд и нелюбимых блюд.
№º9 Программа которая при вводе значений будет выдавать есть ли паспорт у человека или нет
№10 Программа которая при вводе значений будет указывать погоду например 8 градусов то холодно или 30 градусов тепло)
№10 Программа которая сравнивает числа если они равны, Если 1 число больше выводит число которая больше.
срочнооо дам 100 баллов(Payton)​

Ответы на вопрос

Ответил sergeydoow
1

Ответ:

№6 Написать программу которая выдает цвета радуги. (Использовать 2 способа для получение результата)

# Способ 1: использовать список

colors = ["Красный", "Оранжевый", "Желтый", "Зеленый", "Голубой", "Синий", "Фиолетовый"]

for color in colors:

   print(color)

# Способ 2: использовать словарь

colors = {"Красный": 0, "Оранжевый": 1, "Желтый": 2, "Зеленый": 3, "Голубой": 4, "Синий": 5, "Фиолетовый": 6}

for color in colors:

   print(color)

№7 Написать программу для сравнение двух чисел.

# Вводим два числа

num1 = int(input("Введите первое число: "))

num2 = int(input("Введите второе число: "))

# Сравниваем их

if num1 > num2:

   print("Первое число больше второго")

elif num1 < num2:

   print("Второе число больше первого")

else:

   print("Числа равны")

Код, созданный ИИ. Внимательно просмотрите и используйте. Дополнительные сведения о часто задаваемых вопросах.

№ 8 Создать список своих любимых блюд и нелюбимых блюд.

# Создаем список любимых блюд

favorite_foods = ["Борщ", "Пельмени", "Пицца", "Суши", "Шашлык"]

# Создаем список нелюбимых блюд

hated_foods = ["Окрошка", "Каша", "Оливье", "Гречка", "Салат"]

# Выводим списки на экран

print("Мои любимые блюда:")

for food in favorite_foods:

   print(food)

print("Мои нелюбимые блюда:")

for food in hated_foods:

   print(food)

№ 9 Программа которая при вводе значений будет выдавать есть ли паспорт у человека или нет

# Вводим возраст человека

age = int(input("Введите возраст человека: "))

# Проверяем, есть ли у него паспорт

if age >= 16:

   print("У человека есть паспорт")

else:

   print("У человека нет паспорта")

№10 Программа которая при вводе значений будет указывать погоду например 8 градусов то холодно или 30 градусов тепло)

# Вводим температуру воздуха

temp = int(input("Введите температуру воздуха: "))

# Определяем, какая погода

if temp < 0:

   print("Морозно")

elif temp < 10:

   print("Холодно")

elif temp < 20:

   print("Прохладно")

elif temp < 30:

   print("Тепло")

else:

   print("Жарко")

№10 Программа которая сравнивает числа если они равны, Если 1 число больше выводит число которая больше.

# Вводим два числа

num1 = int(input("Введите первое число: "))

num2 = int(input("Введите второе число: "))

# Сравниваем их

if num1 == num2:

   print("Числа равны")

elif num1 > num2:

   print("Большее число:", num1)

else:

   print("Большее число:", num2)

Новые вопросы