50+лучший
Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел
(массив не использовать). Сделайте три варианта программы, используя операторы While,Repeat, For.
Ответы на вопрос
Ответил srzontmp
0
var i: integer;
a,s: real;
begin
s:=0;
writeln('числа:');
for i:=1 to 10 do
begin
write(i,': ');
readln(a);
s:=s+a;
end;
writeln('среднее арифметическое: ',s/10:6:2);
end.
a,s: real;
begin
s:=0;
writeln('числа:');
for i:=1 to 10 do
begin
write(i,': ');
readln(a);
s:=s+a;
end;
writeln('среднее арифметическое: ',s/10:6:2);
end.
Новые вопросы