Информатика, вопрос задал dnk2345 , 6 лет назад

50 баллов
ПИТОН

Требуется найти все способы выплаты n рублей монетами по 1, 2, 5 и 10 рублей.


Формат входных данных

На вход программе дается одно натуральное число n (n≤100).


Формат выходных данных

Очередной вариант оплаты выводить в формате «d tens f fives t twos o ones», где d, f, t, o — количество монет достоинством 10, 5, 2 и 1 соответственно. Требуется выводить очередной вариант оплаты с новой строчки. Порядок перечисления вариантов оплаты не важен.


Например:

входные данные:
3
выходные данные:
0 tens 0 fives 0 twos 3 ones
0 tens 0 fives 1 twos 1

Ответы на вопрос

Ответил Kvint123
5

Ответ:

n=int(input())

for o in range(0,101):

   for t in range(0,51):

       for f in range(0,21):

           for d in range(0,11):

               x=1*o+2*t+5*f+10*d

               if x==n:

                   print(d,'tens', f, 'fives', t, 'twos', o, 'ones')

Объяснение:

Новые вопросы