50 баллов.Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 13. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 13. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число - минимальное число, кратное 13. Входные данные 3, 130, 25, 169. Выходные данные 130. (чтобы её можно было запустить в паскаль)
Ответы на вопрос
Ответил dim4942
0
Ответ:
Var i,c,count,min:integer;
Begin
Read (count);
Min:=30000;
For i:=1 to count do
Begin
Read(c);
If c < min and c mod 13 = 0 then
Min:= c;
End;
Write(min);
End.
Ответил bvcwg
0
#include <iostream>
using namespace std;
int main()
{
int b,c,d,e,f,g;
cin >>b;
d=30001;
int A[b];
for ( int i=0;b>i;i++ )
{
cin >> A[i];
}
for ( int i=0;b>i;i++ )
{
if ( A[i]%13 ==0 )
{
if ( A[i]< d )
{
d=A[i];
}
}
}
cout << d;
}
Ответил eugene7870
0
зачем так усложнять? или это троллинг? :)))
Новые вопросы