Информатика, вопрос задал userunknown8 , 1 год назад

50 БАЛЛОВ написать программу , которая подсчитывает сумму натуральных чисел от 1 до n (с циклом for, while, repeat

Ответы на вопрос

Ответил Helper211
2

Ответ:

ЦИКЛ FOR:

var s,i,n: integer;

begin

write('Введите n: ');

readln(n);

s:=0;

for i:=1 to n do

s:=s+i;

writeln('Сумма равна ',s);

end.

ЦИКЛ WHILE:

var s,i,n: integer;

begin

write('Введите n: ');

readln(n);

s:=0;

i:=1;

while (i<=n) do

begin

s:=s+i;

i:=i+1;

end;

writeln('Сумма равна ',s);

end.

ЦИКЛ REPEAT:

var s,i,n: integer;

begin

write('Введите n: ');

readln(n);

s:=0;

i:=1;

repeat

s:=s+i;

i:=i+1;

until i>n;

writeln('Сумма равна ',s);

end.

Новые вопросы