5) Напишите программу, которая получает случайное натуральное число из отрезка [64; 511] и выводит на экран запись этого числа в восьмеричной системе счисления. Оформите вывод так, как в примере:
Случайное число 83
В восьмеричной системе 123
Ответы на вопрос
Ответил evtehov6199
0
Ответ:
Procedure dec2oct(n: longint); { перевод натурального десятичного n в восьмеричную систему счисления и вывод результата } const alpha = '01234567'; var s: string; i: integer; begin s : = ''; while n > 0 do begin s : = alpha[(n mod 8) + 1] + s; n : = n div 8 end; for i: =length(s) to 9 do s: ='0'+s; write(s) end; { использование } var x: longint; begin write('введите десятичное число: '); read(x); write('в восьмеричной системе счисления: '); dec2oct(x); writeln end. тестовое решение: введите десятичное число: 1234567 в восьмеричной системе счисления: 0004553207
Объяснение:
Belochka21:
pascal
Новые вопросы