Информатика, вопрос задал mikhailplotnikov , 7 лет назад

46 БАЛЛОВ! ПОМОГИТЕ СОСТАВИТЬ ПРОГРАММУ НА ПАСКАЛЕ!
Рассчитать сумму кубов всех положительных значений и их количество для функции

Составить программу для табулирования функции на промежутке [0;4] с шагом h=0,5.

Приложения:

Ответы на вопрос

Ответил BobbyFresnel
0

===== PascalABC/NET =====

begin

 var (a, b, h) := (0.0, 4.0, 0.5);

 var n := Trunc((b - a) / h) + 1; // количество точек

 var (s, k) := (0.0, 0);

 for var i := 0 to n - 1 do

 begin

   var x := a + i * h;

   var y := 3 * x * x + 2 * Cos(Cos(x));

   Writeln(x:3:1, y:20:15);

   if y > 0 then

   begin

     Inc(k);

     s += y ** 3

   end

 end;

 Println('Сумма кубов положительных значений функции равна', s);

 Println('Количество вошедших в сумму значений равно', k)

end.

Приложения:
Новые вопросы