40 баллов
1. Напишите программу, которая в последовательности натуральных чисел определяет сумму 3-хзначных нечетных чисел. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число. Если избранных чисел нет, вывести «NO»
2. Напишите программу, которая в последовательности натуральных чисел определяет количество и среднее значение суммы чисел, кратных 8, и оканчивающихся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 100. Введённые числа не превышают 300. Избранные числа всегда есть. Программа должна вывести два числа.
Pemex:
Прошу, решите это, очень срочно нужно отправить
Ответы на вопрос
Ответил stesis
1
Ответ:
Объяснение:
1)
var a,b,x,i:integer;
begin
readln(a);
x := 0;
for i := 1 to a do
begin
readln(b);
if (b div 100 > 0) and (b div 100 < 10) and (b mod 2 = 0) then
x := x+b;
end;
if x <> 0 then
writeln(x)
else
writeln('NO')
end.
2)
var a,b,x,i,c:integer;
begin
readln(a);
x := 0;
c :=0;
for i := 1 to a do
begin
readln(b);
if ((b mod 10 = 4 ) or (b mod 100 = 4)) and (b mod 8 = 0 ) then
begin
c:=c+b;
x := x+1;
end;
end;
writeln(c/x);
writeln(x)
end.
Новые вопросы
Английский язык,
1 год назад
Французский язык,
1 год назад
Математика,
1 год назад
Русский язык,
1 год назад
Қазақ тiлi,
7 лет назад
Английский язык,
7 лет назад