40+20б! Помогите пожалуйста решить задачу через паскаль.
Составьте программу, которая выводит на экран таблицу перевода а,а+1, а+2........в . бит в килобайты. Границы а и в вводятся с клавиатуры.
Приложения:

Ответы на вопрос
Ответил nelle987
0
var
i, a, b: integer;
begin
write('Введите границы: ');
readln(a, b);
for i := a to b do
writeln(i, ' бит = ', i/8/1024:1:5, ' Кб');
end.
i, a, b: integer;
begin
write('Введите границы: ');
readln(a, b);
for i := a to b do
writeln(i, ' бит = ', i/8/1024:1:5, ' Кб');
end.
Ответил nastya151192033
0
Простите, а зачем делить кроме как на 8 и 1024, еще на 1 и 5?
Ответил Аноним
0
8 бит = 1 байт. 1024 байта = 1 кбайт => в одном кбайте 1024*8 бит. Значит и делить нужно на (8*1024), ну или на каждое /8/1024
Ответил nastya151192033
0
Но зачем делить на 5?
Ответил nelle987
0
Это не деление, это форматированный вывод. Число:a:b означает, что на число требуется отвести a символов (если не влезает, ширина увеличивается), и точно b символов после запятой.
Новые вопросы
Другие предметы,
2 года назад
Геометрия,
2 года назад
Математика,
8 лет назад
Математика,
8 лет назад
Химия,
9 лет назад
История,
9 лет назад