Информатика, вопрос задал etokto53 , 2 года назад

4. Составьте программу, выдающую результат следующего выражения:
(1+2)*(1+2+3)*...*(1+2+...+10)
5. Задано натуральное число N. Найти количество натуральных чисел, не
превосходящих его и не делящихся ни на одно из чисел 2, 3, 5.
на PHyton

Ответы на вопрос

Ответил timkafey
0

4)

numbers = []

for i in range(1, 11):

 numbers.append(0)

 for z in range(1, i + 1):

   numbers[i - 1] += z

composition = numbers[0]

for i in range(1, len(numbers)):

 composition *= numbers[i]

print(composition)

5)

n = int(input())

amountOfNumbers = 0

for i in range(n + 1):

 if i % 2 != 0 and i % 3 != 0 and i % 5 != 0:

   amountOfNumbers += 1

print(amountOfNumbers)

Новые вопросы