Информатика, вопрос задал тянка15 , 8 лет назад

4. Составить программу для решения следующей задачи.
(Уровень А):
Даны катеты прямоугольного треугольника a и b. Найти его площадь S=½*a*b.
(Уровень B):
Дано целое число. Если оно кратно 3, то удвоить его. В противном случае уменьшить его на величину остатка отделения этого числа на 3. Вывести полученное число.
(Уровень C):
Найти сумму положительных нечетных чисел, меньших 100.

Ответы на вопрос

Ответил Johnny21
0
Реализация на с++

Уровень А
#include<iostream.h>

using namespace std;

int main(){
  int a,b;
  cin >>a >> b;
  double s = 0.5 * a * b;
  cout << s << endl;
  return 0;
}
Уровень B
#include<iostream.h>

using namespace std;

int main(){
  int n;
  cin >> n;
  (n%3==0) ? n*2 : n+n%3;
  cout << n << endl;
  return 0;
}
Уровень C
#include<iostream.h>

using namespace std;

int main(){
  int summa = 0;
  for(int i = 1; i < 100; i+=2){
     summa += i;
  }
  cout << summa << endl;
  return 0;
}
Новые вопросы