4. Написать программу, которая вводит с клавиатуры номер месяца и зависимости от номера месяца, выводит на экран одно из слов: Зима, Весна, Лето или Осень.
Ответы на вопрос
Ответил surfs1
0
#include <iostream>
using namespace std;
int main(){
while (1) { setlocale(0, "rus"); int number;
cout << "Введите номер месяца " << endl; cin >> number; switch (number) { case 1: case 2: case 12: cout << "Зима " << endl; break; case 3: case 4: case 5: cout << "Весна " << endl; break; case 6: case 7: case 8: cout << "Лето " << endl; break; case 9: case 10: case 11: cout << "Осень " << endl; break; }
}
return 0;
}
using namespace std;
int main(){
while (1) { setlocale(0, "rus"); int number;
cout << "Введите номер месяца " << endl; cin >> number; switch (number) { case 1: case 2: case 12: cout << "Зима " << endl; break; case 3: case 4: case 5: cout << "Весна " << endl; break; case 6: case 7: case 8: cout << "Лето " << endl; break; case 9: case 10: case 11: cout << "Осень " << endl; break; }
}
return 0;
}
Приложения:

Ответил Аноним
0
// PascalABC.NET 3.2, сборка 1488 от 21.06.2017
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('Введите номер месяца (1-12):');
case n of
3,4,5:Writeln('Весна');
6,7,8:Writeln('Лето');
9,10,11:Writeln('Осень');
12,1,2:Writeln('Зима')
else Writeln('Неверный номер')
end
end.
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('Введите номер месяца (1-12):');
case n of
3,4,5:Writeln('Весна');
6,7,8:Writeln('Лето');
9,10,11:Writeln('Осень');
12,1,2:Writeln('Зима')
else Writeln('Неверный номер')
end
end.
Приложения:

Новые вопросы