4!+a!-10 a-целое число ,найти факториал ,составить программу паскаль
Ответы на вопрос
Ответил Gleb1Kosyrev
0
//PascalABC.NET 3.2 сборка 1318
Var
a:integer;
function fact(a:integer):integer;
begin
if a=0 then fact:=1 else fact:=fact(a-1)*a;
end;
begin
readln(a);
writeln(fact(4)+fact(a)+10);
end.
Пример ввода:
4
Пример вывода:
58
Var
a:integer;
function fact(a:integer):integer;
begin
if a=0 then fact:=1 else fact:=fact(a-1)*a;
end;
begin
readln(a);
writeln(fact(4)+fact(a)+10);
end.
Пример ввода:
4
Пример вывода:
58
Новые вопросы