Информатика, вопрос задал 10kek , 7 лет назад

(35 БАЛЛОВ ИЗИ ЗАДАНИЕ!)
Написать программу вычисления суммы всех нечетных двузначных чисел
Написать 3 программы!
Через: 1)while 2)repeat 3)for

Ответы на вопрос

Ответил shavrinatv
0

Ответ:

Объяснение:

 var i,s:integer;

 begin

   i:=10;s:=0;

   for i:=10 to 99 do

   if i mod 2<>0 then s:=s+i;

  writeln('Сумма нечетных 2-значных чисел(for)',s);

  readln;

  i:=10;s:=0;

  while i<=99 do

    begin

      if i mod 2<>0 then s:=s+i;

      i:=i+1;

    end;

    writeln('Сумма нечетных 2-значных чисел(while)',s);

    readln;

    i:=10;s:=0;

   repeat

    if i mod 2<>0 then s:=s+i;

    i:=i+1;

   until i>99 ;

   writeln('Сумма нечетных 2-значных чисел(repeat)',s);

   readln;

end.

Ответил 10kek
0
Спасибо:)
Новые вопросы