30 БАЛЛОВ, ПАСКАЛЬ
Решить каждую задачу
Составить программу, печатающую значение true, если указанное высказывание является истинным, и false в противном случае:
Сумма цифр данного трехзначного числа N является четным числом.
Квадрат заданного трехзначного числа равен кубу суммы цифр этого числа.
Треугольник со сторонами a, b, c является равнобедренным.
Ответы на вопрос
Первая
var n,x:integer;
begin
readln(n);
while n <> 0 do begin
x:=x + n mod 10;
n:=n div 10;
end;
if(x mod 2 = 0) then
writeln('true')
else
writeln('false');
end.
Вторая
var x,z,s:integer;
begin
readln(x);
if (x > 99) and (x < 1000) then begin
s:=x;
while s<>0 do begin
z:=z+s mod 10;
s:=s div 10;
end;
if(x*x) = (z*z*z) then
writeln('true')
else
writeln('false');
end
else
writeln('Число должно быть 3-ех значным!');
end.
Третья
Var a,b,c:Real;
Begin
Writeln('Введите a');
Readln(a);
Writeln('Введите b');
Readln(b);
Writeln('Введите c');
Readln(c);
if (a=b) or (a=c) or (b=c) then
writeln ('true')
else
writeln ('false);
end.