30 баллов
Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. Паскаль.
Ответы на вопрос
Ответил maratainara2011
0
var
n:word;
a,max,i:integer;
begin
repeat
write ('N = ');readln(n);
until (n>0) and (n<=1000);
write ('A = ');readln(a);
if a mod 5 = 0 then max:=a;
while i<>n-1 do begin
write ('A = ');readln(a);
if (a>max) and (a mod 5 = 0) then max:=a;
i:=i+1;
end;
writeln ('Max: ',max);
readln;
end.
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Английский язык,
2 года назад
Химия,
2 года назад
Математика,
8 лет назад