30 (60) баллов!!
Напишите программу для решения следующей задачи. В некотором году на участке в К гектаров средняя урожайность ячменя составила А центнеров с гектара. После этого каждый год площадь участка увеличивалась на Р%, а средняя урожайность - на В%. Через сколько лет урожай превысит М центнеров.
Ответы на вопрос
Ответил raf1O5
0
program raf105;
var k,a,p,b,m,let:real;
begin
write('Площадь участка (га.): ');
readln(k);
write('Средняя урожайность с гектара (ц.): ');
readln(a);
write('Увеличение участка за год (% от прошлогодней площади): ');
readln(p);
write('Рост урожайности за год (% от прошлогодней урожайности): ');
readln(b);
write('Желаемый урожай (ц.): ');
readln(m);
while a < m do
begin
k+= (k/100*p);
a+= (a/100*b);
let+= 1;
end;
writeln;
writeln('Желаемая урожайность (',m,' ц.) будет достигнута через ',let,' лет');
writeln('При этом, площадь участка будет составлять примерно ',round(k),' га.');
end.
Язык программирования PascalABC
Ответил AnnStarina
0
Можете еще одну программу составить? Дам сорок баллов
Новые вопросы