Информатика, вопрос задал Redhry , 8 лет назад

№3. Составьте программу в Pascal: С клавиатуры вводится трехзначное число. Определить является ли сумма его цифр двухзначным и четным числом. Используйте: Ввод данных – Read. Вывод данных – Write. Проверка условий - If Then Else. Логическое «И» - AND

Ответы на вопрос

Ответил Dave11ar
0
Program pascal;
var a, b1, b2, b3, c:integer;
begin
read(a);
b1:=a mod 10;
b2:=(a mod 100) div 10;
b3:=a div 100;
c:=b1+b2+b3;
if (c>=10) and (c<100) and (c mod 2=0)then
write('Yes')
else
write('No');
end.
Новые вопросы