Информатика, вопрос задал LSM54 , 2 года назад

25 баллов! Python. Напишите программу, которая просит ввести три комплексных числа и вычисляет корни соответствующего квадратного уравнения и печатает их. Импортируйте библиотеку cmath (и используйте её функцию sqrt для вычисления квадратного корня). Вычисление корней (без их печати) оформите в виде вспомогательной функции.

Ответы на вопрос

Ответил sergeypolumardenov
1

Ответ:

import cmath

def solve(a, b, c):

   desc = cmath.sqrt(b**2-4*a*c).real

   if desc < 0:

       return

   if desc == 0:

       return (-b)/(2*a)

   # если дискриминант меньше либо равен нуля, то до сюда программа уже не дойдет, а значит дополнительных условий больше не нужно.

   x1 = (-b+desc)/(2*a)

   x2 = (-b-desc)/(2*a)

   return x1, x2

a = int(input("Введите а"))

b = int(input("Введите b"))

c = int(input("Введите c"))

print(solve(a, b, c))

Новые вопросы