Информатика, вопрос задал sdeffx55 , 6 лет назад

25 баллов
напишите программу

Приложения:

DiannaAstana: какой язык

Ответы на вопрос

Ответил StellarisY
0

Python

n = int(input())    //количество чисел

k = 0  //задаем сумму изначально 0

for i in range(n):

   x = int(input())    //в цикле вводим числа

   if x % 4 == 0 and x % 7 != 0:   //проверка на кратность 4 и 7

       k = k + 1    //если проверка прошла, кол-во увеличиваем на 1

print(k)    //вывод кол-ва

Pascal

var n,i,a,k: integer;

begin

readln(n);  //ввод количества чисел

k := 0;     //задаем сумму изначально 0

for i := 1 to n do

begin

  readln(a);    //считываем с клавиатуры в цикле числа

  if (a mod 4 = 0) and (a mod 7 <> 0)     //проверка на кратность

               then k:=k+1;     //прошла проверка - увеличиваем кол-во на 1

end;

writeln(k)    //кол-ва

end.

Новые вопросы