Информатика, вопрос задал dondokovakrist , 9 лет назад

20 баллов!!!
Составить программу подсчета четных чисел из n водимых с клавиятуры

Ответы на вопрос

Ответил GoldenDragon777
0
python 3.1
а=list(map(int, input().split())) #Вводится массив из чисел а
length=0 #создаём счетчик
for elem in a: #рассмотрим каждый элемент в последовательности а
       if a%2==0: #если остаток от деления на 2 равен 0
              length+=1 #счётчик +1
print(length) #выведите счётчик

Ответил GoldenDragon777
0
Повторяю это моё решение. Очень простое и понятное. Я не знаю всх встроенных функций питона, и пиши это опытный программист, его решение было бпрощ бы гораздо короче.
Ответил Аноним
0
Мое уж куда проще? Читаем строку, превращаем в последовательность целых чисел, отбираем из них четные и выводим их количество.
Ответил GoldenDragon777
0
Я не говорю, что прощего Вашего, я имею ввиду, что проще моего.
Ответил GoldenDragon777
0
Скорее всего это была бы тоже одна строчка
Ответил Аноним
0
Да. с лямбдами - одна. Но примерно вдвое длиннее моей.
Новые вопросы