Информатика, вопрос задал ShurimanGrei , 7 лет назад

20 баллов. С циклом while

Составить программу, которая запрашивает пароль (трехзначное число + 2 символа) до тех пор, пока он не будет правильно введен. Верный пароль должен быть задан в виде константы.
И лучше скинуть скрин

Ответы на вопрос

Ответил FunnyPro
0

Відповідь:

# на пайтоне

kod = str(input("Введи свой код:"))

v = ''

while(kod != v):

    v = str(input("Код:"))

    if(v != kod):

          print("Неправильно!")

print("Правильно")

Пояснення:

Не до конца зделано.Нету константа,и проверки кода (трехзначное число + 2 символа)

Приложения:
Ответил KnowsUser1
0
Имя "kod" в вашей программе написано транслитом от русского "Код". Так делать нехорошо. Это смотрится не красиво. Вы бы могли использовать имя password (pass, pw, psw) или добавить в начало программы строку с указанием кодировки, поддерживающей кириллицу, и использовать нормальное русское "код".
Ответил KnowsUser1
0

Ответ:

Язык в вопросе не указан. Сделаю на двух, выбирай сам какой пойдёт.

### Пыхтон

PASS = '123bc'

rpass = input('Введите пароль:n')

while rpass != PASS:

   rpass = input('Неверный пароль. Попробуйте ещё: n')

else:

   print('Доступ разрешён')

###PascalABC.NET

const PASS = '123bc';

begin

 var rpass := readstring('Enter password: ');

 while (rpass <> PASS) do begin

   rpass := readstring('Access denied. Try again: ');

 end;

 print('Access allowed. Welcome');

end.

Скрины - на чёрном фоне - Пайтон, на белом - Паскаль. Тестировал, работает.

Приложения:
Новые вопросы