Информатика, вопрос задал ekaterinabelyaeva1 , 9 лет назад

20 БАЛЛОВ ПОМОГИТЕ ПОЖАЛУЙСТА!!!
Задание 1:
В программе «:=» обозначает оператор присваивания, знаки «+», «-», «*» и «div» — соответственно
операции сложения, вычитания, умножения и частное от деления с остатком. Правила выполнения операций и порядок действий соответствуют правилам арифметики. Определите значение целочисленных переменных х и у после выполнения фрагмента программы:
х := 19
у := 3
z := у*2
у := х div у
х := х-z
у := у+z
Задание 2:
Определите, что будет напечатано в результате работы следующего фрагмента программы:
var n, s: integer;
begin
n := 0;
s := 0;
while s <=365 do begin
s := s + 36;
n := n + 10
end;
write(n)
end.
Задание 3:
В программе описан одномерный целочисленный
массив с индексами от 0 до 10. В приведенном ниже фрагменте программы массив
сначала заполняется, а потом изменяется:

for i:=0 to 10 do
A[i]:=i + 1;
for i:=10 downto 0 dо
A[i]:=A[10-i];

Ответы на вопрос

Ответил TaTaPmember
0
1)Значит выполняем последовательно.
z:=y*2 -> z=3*2=6;
y:= x div y -> y=19/3=6, т.к. DIV делит делимое без остатка.
x:=x-z -> x=19-6=13;
y:=y-z -> y=6-6=0;
x=13 y=0.
2)Посчитаем сколько раз выполниться цикл WHILE для S.
Для этого 365/36=10 (примерно), это значит цикл выполниться 10 раз, но условие у нас для Цикла с предусловием стоит что S<=365, посчитаем сколько даст нам перемножение кол-во повторов и самого числа: 10*36=360.
Мы видим что цикл должен выполниться еще раз, поскольку условие подходит -> N Будет прибавлять 10 раз по 10, и еще в добавок один раз.
Выходит N=10*11=110.
3)Начальный массив равен:
A[0]=1 A[1]=2 A[2]=3 A[3]=4 A[4]=5 A[5]=6 A[6]=7 A[7]=8 A[8]=9 A[8]=10 A[10]=11
После выполнения второй части программы значения поменяются местами:
A[0]=11 A[1]=10 A[2]=9 A[3]=8 A[4]=7 A[5]=6 A[6]=5 A[7]=4 A[8]=3 A[8]=2 A[10]=1


Ответил ekaterinabelyaeva1
0
спасибо большое
Новые вопросы