Информатика, вопрос задал cosmocmolecule , 6 лет назад

20 баллов.
Напишите программу, которая вводит с клавиатуры два целых числа и вычисляет их произведение, используя только операции сложения. Учтите, что числа могут быть отрицательными.

Ответы на вопрос

Ответил alexshor
0

Ответ:

результат в приложении

Объяснение:

#!/usr/bin/env python3

x = int(input('Введите первое число: '))

y = int(input('Введите второе число: '))

sum = 0

if x > 0:

   for i in range(x):

       sum += y

elif y > 0:

   for i in range(y):

       sum += x

else:

   for i in range(abs(y)):

       sum += abs(x)

print(x, '*', y, '=', sum)

Приложения:
Новые вопросы