20.2 (№ 987) Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 8, или сообщает, что таких чисел нет (выводит «NO»). Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести среднее арифметическое чисел, кратных 8, или вывести «NO», если таких чисел нет. Значение выводить с точностью до десятых. Пример работы программы:
Ответы на вопрос
Ответил AnonimusPro
0
Program n1;
var sum,k,a: integer;
begin
readln(a);
sum:=0;
k:=0;
while a<>0 do
begin
if a mod 8=0 then begin
k:=k+1;
sum:=sum+a;
end;
readln(a);
end;
if k=0 then write('NO')
else write(sum/k:0:1);
end.
var sum,k,a: integer;
begin
readln(a);
sum:=0;
k:=0;
while a<>0 do
begin
if a mod 8=0 then begin
k:=k+1;
sum:=sum+a;
end;
readln(a);
end;
if k=0 then write('NO')
else write(sum/k:0:1);
end.
Новые вопросы