2 задания по С++ срочно 100
баллов !!!!! 1 задание
дан массив из N элементов.вычичлить сумму элементов массива, расположенных после минимального элемента массива
2 задание
написать программу которая вводит с клавиатуры последовательность из пяти дробных чисел и после ввода каждого числа выводит среднее арифметическое введенной части последовательности
Ответы на вопрос
Ответил Аноним
0
#include <iostream>
using namespace std;
int main() {
int n;
cin >> n;
int a[n];
cin >> a[0];
int s(0), min=a[0];
for (int i(1); i<n; i++) {
cin >> a[i];
if (a[i]<min) { s=0; min=a[i]; }
else s+=a[i];
}
cout << "s = " << s << "n";
return 0;
}
------------------------------------
#include <iostream>
using namespace std;
int main() {
double a[5];
double s(0.0);
for (int i(0); i<5; i++) {
cin >> a[i];
s+=a[i];
cout << "avg = " << s/(i+1) << "n";
}
return 0;
}
using namespace std;
int main() {
int n;
cin >> n;
int a[n];
cin >> a[0];
int s(0), min=a[0];
for (int i(1); i<n; i++) {
cin >> a[i];
if (a[i]<min) { s=0; min=a[i]; }
else s+=a[i];
}
cout << "s = " << s << "n";
return 0;
}
------------------------------------
#include <iostream>
using namespace std;
int main() {
double a[5];
double s(0.0);
for (int i(0); i<5; i++) {
cin >> a[i];
s+=a[i];
cout << "avg = " << s/(i+1) << "n";
}
return 0;
}
Приложения:


Новые вопросы