2
Составьте программу на языке Паскаль для нахождения периметра
прямоугольника Р, если известны сторона a прямоугольника и его площадь S.
Пропишите диалог компьютера с пользователем. Протестируйте программу
(входные данные: 8, 2; выходные данные: 16,5). Программу сохраните в файле под
именем «Периметр прямоугольника».
Ответы на вопрос
Вот программа на языке Паскаль для нахождения периметра прямоугольника P, если известны сторона a прямоугольника и его площадь S:
Delphi
program PerimeterRectangle;
var
a, b, S, P: real;
begin
writeln('Введите сторону a прямоугольника: ');
readln(a);
writeln('Введите площадь S прямоугольника: ');
readln(S);
b := S / a;
P := 2 * (a + b);
writeln('Периметр прямоугольника P равен: ', P);
end.
Эта программа сначала запрашивает у пользователя ввод значения стороны a прямоугольника. Затем она запрашивает ввод значения площади S прямоугольника.
Затем программа вычисляет значение стороны b прямоугольника по формуле S = ab.
Наконец, программа вычисляет периметр прямоугольника по формуле P = 2 * (a + b) и выводит его на экран.
Вот результат выполнения программы с входными данными 8 и 2:
Введите сторону a прямоугольника: 8
Введите площадь S прямоугольника: 2
Периметр прямоугольника P равен: 16,5
Вот диалог компьютера с пользователем:
Введите сторону a прямоугольника: 8
Введите площадь S прямоугольника: 2
Периметр прямоугольника P равен: 16,5
Чтобы сохранить программу в файл под именем «Периметр прямоугольника», необходимо сохранить ее в текстовом редакторе с указанным именем.