Информатика, вопрос задал dsimsss , 2 года назад

2. Составить программу для нахождения 25-го элемента арифметической прогрессии. Первый элемент равен 5. Приращение прогрессии (шаг) равен 6.
3. В одномерном массиве b[n], заданном с помощью датчика случайных чисел, найти максимальный элемент.

Помогите плиз.

Приложения:

Plus9ToIntellect: А язык какой?
dsimsss: Pascal
Plus9ToIntellect: У-у-у. Тогда не помогу, сорри(
dsimsss: А на каком языке умеете ?
Plus9ToIntellect: С++, Python
dsimsss: на С++ тоже можно, если вам не сложно, сделаете пожалуйста ?
Plus9ToIntellect: Постараюсь, не обещаю насчёт того, что на картинке(
Plus9ToIntellect: в 3 заполнить случайными числами?
dsimsss: Да
dsimsss: vectorarr(n);

for(int i = 0;i
arr[i]=rand()%100; что это означает ?

Ответы на вопрос

Ответил Plus9ToIntellect
1

//FIRST

#include <iostream>

using namespace std;

int main()

{

   int n1;//Первый элемент

   cin>>n1;

   int step;//Шаг прогрессии

   cin>>step;

   int quantity;//Какой элемент найти

   cin>>quantity;

   cout<<n1+ (quantity-1)*step;

   return 0;

}

//-----------------------------------------------------------------------------------------

//SECOND

//Использовал STL

#include <iostream>

#include <ctime>

#include <cstdlib>

#include <algorithm>

#include <vector>

using namespace std;

int main()

{

   srand(time(NULL));

   int n;

   cin>>n;

   vector<int>arr(n);

   for(int i = 0;i<n;i++){

       arr[i]=rand()%100;

   }

   sort(arr.begin(), arr.end());

   cout<<arr[n-1];

   return 0;

}

//4 - X3


dsimsss: Огромное спасибо!
Plus9ToIntellect: :)
Новые вопросы