2. Напишите программу вычисления в массиве из n элементов, заданных датчиком случайных чисел из промежутка от -13 до 25, количества четных элементов.
Ответы на вопрос
Ответил APALoff
0
Const n = 10;
Var
i,k : Byte;
m : array[1..n] of Integer;
Begin
Randomize;
k:=0;
For i:=1 to n do
Begin
m[i]:=-13+Random(39);
Write(m[i],' ');
If not Odd(m[i]) then Inc(k);
end;
Writeln;
Writeln('Количество чётных элементов: ',k);
end.
Var
i,k : Byte;
m : array[1..n] of Integer;
Begin
Randomize;
k:=0;
For i:=1 to n do
Begin
m[i]:=-13+Random(39);
Write(m[i],' ');
If not Odd(m[i]) then Inc(k);
end;
Writeln;
Writeln('Количество чётных элементов: ',k);
end.
Ответил egunovinc
0
Спасибо тебе , спас
Ответил egunovinc
0
Ошибку выводит в этой строчке : m[i]:=-13+Random(39);
Ответил APALoff
0
упс, это я забыл описать сам массив
Ответил APALoff
0
после Var добавить: m : array[1..n] of Integer;
Ответил APALoff
0
исправил сам ответ
Ответил Аноним
0
// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
begin
var a:=ArrRandom(Readinteger('n='),-13,25); a.Println;
Writeln('k=',a.Where(x->x.IsEven).Count)
end.
Тестовое решение:
n= 15
17 20 22 -11 1 10 22 3 1 3 16 9 23 -8 15
k=6
begin
var a:=ArrRandom(Readinteger('n='),-13,25); a.Println;
Writeln('k=',a.Where(x->x.IsEven).Count)
end.
Тестовое решение:
n= 15
17 20 22 -11 1 10 22 3 1 3 16 9 23 -8 15
k=6
Новые вопросы